Unanswered topicsActive topics

Honda Elysion in-depth Review of: The King of MPV

User avatar
mt88
6000rpm VTEC ON
6000rpm VTEC ON
Posts: 344
Joined: Tue Feb 21, 2006

Postby mt88 » Fri Jul 15, 2011 8:36 am

alex6328 wrote:Hi mt88,

I have a RR3 (2004). I have the same problem with the bearings as you. I just wonder which is the part number of the Rear Bearing for my RR3. You stated you have changed over the bearing too. The item number is 42200 SJL 951. Is it the one for RR3? I got a 42200 SJL 951 from Japan but it does not look the same as the original one my technician removed from my car.

The old one has sealed core but the new one is not. I am not sure if I got a correct bearing. Could you help?

Thanks in advance.


Image
Image

You may want to check with your parts importer/seller. RR1 and RR3 share a same rear bearing (enclosed type) which is on the picture above (actual bearing). It is the same parts number on newer part catalogue as well the old one. Hope that helps.

You are welcome to post yours.

PS: I am in HK now but leaving later in the afternoon. Saw silver RR3 yesterday at Penisula Kowloon. Rare sight :)
Justice gives our right, but Mercy and Grace give what we don’t deserve

alex6328
Posts: 3
Joined: Thu Jul 14, 2011

Front Bearing

Postby alex6328 » Mon Jul 25, 2011 9:16 pm

Hi mt88,

Rear bearing fixed. I replaced the front bearing too. However, after replacement, ABS failure lighted up at dashboard. My technician checked with the computer and returned the front right sensor failure so I replaced the sensor too. But it does not fix it. Do you have any idea? Is it possible that the front bearing installed not properly so cause the problem?

Thanks in advance.

User avatar
reymund77
4000rpm
4000rpm
Posts: 154
Joined: Mon Oct 31, 2005
Location: West
Contact:

Postby reymund77 » Tue Jul 26, 2011 12:11 pm

Where did you bought the bearings? I've suffered the same situation when I bought bearings directly and send down to workshop to fix up....

Bearings came in "Honda box with Honda part number stickers"...however, actual bearings is "made in china" and they had faulty ABS sensors thus when fixed back ABS sensor lighted up and car speed became limited....cleaning the ABS sensor does not help and computer scan show faulty ABS sensor clearly.

Seller replaced with original Honda bearings (NTN I think) and all problem solved...built quality when compare is definetly different....seller acknowledge the problem and apologize so case closed and happy car is working well.
Image

alex6328
Posts: 3
Joined: Thu Jul 14, 2011

ABS Light

Postby alex6328 » Tue Jul 26, 2011 12:53 pm

The bearing seems come from China. It has identical dimensions as the old one removed but label on part shows different part number. Not sure if the bearing will affect ABS system.

I hear some sharp noise when the car is stpping up speed. Do you know which part has problem?

User avatar
mt88
6000rpm VTEC ON
6000rpm VTEC ON
Posts: 344
Joined: Tue Feb 21, 2006

Postby mt88 » Sat Jul 30, 2011 6:40 pm

Original bearing comes in the buble pack plastic with parts number stick on it.

Image

Image

Please ensure to tie the hanging front brake during exchange as not to strain the brake hose unnecessarily.

Image

Alex I agree with Reymund to use original parts from Japan. Hope you can solve yours too.

After all the bearings replaced with genuine parts, the car runs smoothly and queitly just like new. Fuel consumption also improve back to original.
Justice gives our right, but Mercy and Grace give what we don’t deserve

User avatar
reymund77
4000rpm
4000rpm
Posts: 154
Joined: Mon Oct 31, 2005
Location: West
Contact:

Postby reymund77 » Mon Aug 01, 2011 10:49 am

frankly, u be shock...the bearings I got came with same stickers and packed in the similar brown box like original...stickers and box can all be done and repacked locally or from china factory.......

Just note the original bearings brand for Honda is normally NTN / NSK and they are laser etched or "engraved" onto the bearings sidewall....it will be much easier if you have original and Made in China / cheong to compare....else its hard to differentiate quality when u haven seen the original ones......I was caught too until I got hold of the replacement original bearings and compare side by side to note those details and finishings
Image

wanm
Posts: 1
Joined: Tue Aug 09, 2011
Location: malaysia

Postby wanm » Wed Aug 10, 2011 11:29 pm

hi there
Im from malaysia and im new here.
Just bought a 2.4 ely/ Overall im satisfied with this box especially with the sapce and hadling.
But one thing that really make me sick is that my left sliding door gives a creep sound whnever i drive on an uneven road surface ...really piercing my ears .
Can anyone give me a helping hand to resolve this problem ,,,,,really need help help helpppppppppp
:( :( :( :( :(

User avatar
mt88
6000rpm VTEC ON
6000rpm VTEC ON
Posts: 344
Joined: Tue Feb 21, 2006

Postby mt88 » Tue Mar 06, 2012 3:13 pm

wanm wrote:hi there
Im from malaysia and im new here.
Just bought a 2.4 ely/ Overall im satisfied with this box especially with the sapce and hadling.
But one thing that really make me sick is that my left sliding door gives a creep sound whnever i drive on an uneven road surface ...really piercing my ears .
Can anyone give me a helping hand to resolve this problem ,,,,,really need help help helpppppppppp
:( :( :( :( :(


Welcome Wanm. It's been a while since I come to this forum.

Lets see if we can help you. First picture than explanation.

Image

The 'noise' is very subjective and may differ from one car to another of a same model. It may just be a loose screw or a tear and wear parts. Looking at the door construction, the most movable parts which subject to tear and wear are the railing, cabling, motor and door handles. The door itself is vacummed and rested into 2 slots (no 8 and 9) and few rubber holders to secure it. As such you may want to do this few procedures in sequence. One procedure at a time. if still noisy than try the second procedure and so on.

1. Loosen the slots two screws a bit (no 8&9). One slot each time and try to move slightly 0.5 to 1 mm to the side and tighten again. The purpose of this is to create preasure to the loosen door.
2. Put a 0.5-1mm thickness spacer to the rubber no 14 and 15 so it can hold the door tighter. (rubber spacer just like for table or chairs' foot)
3. If these two procedures fails, you may need to open the door and tighten the motor and the brackets inside.

While you are doing these, you may also want to oil your railing, and cabling to smoothen the movement of the door.

Hope that helps
Justice gives our right, but Mercy and Grace give what we don’t deserve

Elysion88
Posts: 1
Joined: Fri Jun 15, 2012

Postby Elysion88 » Fri Jun 15, 2012 9:05 am

Hi bros,

I have just bought a second-hand Elysion 2.4G (it has clocked over 90,000 KM but still runs excellently, engine is smoooooooth) and am preparing to take over the car. Just wondering if anyone can recommend a good workshop with the relevant Elysion expertise in Singapore to service/repair this wonderful car? :D

Also thinking of doing up the following:

a. re-wrap leather seats/steering wheel
b. 3M car mat
c. DVD player (double-din) with GPS + double monitors at back of first-row seats' head-rests

Would be grateful for any recommendations on these too!

Thanks in advance!

PUMPKINS
4000rpm
4000rpm
Posts: 154
Joined: Wed Feb 25, 2004

Postby PUMPKINS » Fri Jul 27, 2012 6:29 pm

Hi any idea from bro here... is it possible to use aftermarket DVD/GPS at front? because thinking to buy a basic elysion that i see only cd display at the navi place.
aftermarket have remote and so many feature nowadays...
hmm i really like ambiance/mood lighting by alphard or merc... any idea to do that for 2nd row and back?
i saw some LED stoplamp... is it aftermarket?
any list of poison? :D
appreciate all input....

andry
1000rpm
1000rpm
Posts: 10
Joined: Mon Jul 06, 2009
Location: indonesia
Contact:

Postby andry » Wed Jan 23, 2013 5:42 pm

Dear mt88,

I have problem with my 3.0L Elysion,
1. yellow Engine indicator light on
2. VSA indicator light on
I have try to switch VSA ON and OFF, but nothing happen

pls help me

thanks

User avatar
UltraBear
7000rpm VTEC ON
7000rpm VTEC ON
Posts: 1272
Joined: Sat Feb 14, 2004
Location: All over Singapore
Contact:

Postby UltraBear » Wed Jan 23, 2013 9:30 pm

bro, any chance you have the ECM or ECU wiring pin out for RB3? I have been looking high and low but just couldn't find the workshop manual for RB3...

well i did purchase one... title says Odyssey up to 2010... but damn... after paying and downloaded the softcopy to realize that its for RB1 and RB2 only...

User avatar
UltraBear
7000rpm VTEC ON
7000rpm VTEC ON
Posts: 1272
Joined: Sat Feb 14, 2004
Location: All over Singapore
Contact:

Postby UltraBear » Wed Jan 23, 2013 9:33 pm

bro, u still hang out at AD?

User avatar
mt88
6000rpm VTEC ON
6000rpm VTEC ON
Posts: 344
Joined: Tue Feb 21, 2006

Postby mt88 » Thu Jan 24, 2013 3:31 pm

PUMPKINS wrote:Hi any idea from bro here... is it possible to use aftermarket DVD/GPS at front? because thinking to buy a basic elysion that i see only cd display at the navi place.
aftermarket have remote and so many feature nowadays...
hmm i really like ambiance/mood lighting by alphard or merc... any idea to do that for 2nd row and back?
i saw some LED stoplamp... is it aftermarket?
any list of poison? :D
appreciate all input....


I saw an Elysion fitted with 5 inch gps with the holder drilled to the dash. Alternatively you can just buy suction multi purpose holder and use one of the latest smartphone like lumia 920 etc for your gps.

Ambiance lighting can be added. You need to got to accesories shop for such. I saw a japanese owner carefully modified his Elysion pillar an insert led light pointing upward by heating up part of it. For me the original lighting and extra footlights are good enough
Justice gives our right, but Mercy and Grace give what we don’t deserve

User avatar
mt88
6000rpm VTEC ON
6000rpm VTEC ON
Posts: 344
Joined: Tue Feb 21, 2006

Postby mt88 » Thu Jan 24, 2013 3:36 pm

andry wrote:Dear mt88,

I have problem with my 3.0L Elysion,
1. yellow Engine indicator light on
2. VSA indicator light on
I have try to switch VSA ON and OFF, but nothing happen

pls help me

thanks


First thing you must do is to go to workshop and check the code/error via ODB. There are too many possibilities of engine lights up. Getting the code will enable you to get to the problem rather than guessing.

VSA lights up sometime because a damaged sensors especially with flood! The best is to get the code!
Justice gives our right, but Mercy and Grace give what we don’t deserve


Return to “Stream / Odyssey / Elysion / Freed”

Who is online

Users browsing this forum: No registered users and 0 guests