Page 1 of 1

Engine reving but no power.........

Posted: Wed Sep 04, 2013 9:54 pm
by Alan B
Hi, I've got a 2008 Airwave, 58k on the clock, which I've owned for 2 years. In the last few weeks it's developed some strange behaviour and is a problem that neither me nor my mechanic can understand.

At speeds below about 50k/hr it seems fine, but if I'm doing around 60-80k/hr on the expressway and I try to accelerate the engine revs go up but I get no power. It feels like something is disengaging, or slipping, and not being able to transfer the power from the engine to the driveshaft.

My first thought was that it's a gearbox problem, but my mechanic's view is that gearbox problem would show itself trying to accelerate from low speed, not just become apparent at higher speeds.

We've changed the CVT fluid, spark plugs, oil and ignition coils. The pull away judder has disappeared as a result of these replacements, but this behaviour at expressway speeds has not improved so must be unrelated.

I welcome any thoughts from the forum members!

Thanks, Alan

Posted: Tue Nov 26, 2013 10:53 pm
by mugenfrv
Contact me i have the solution to your problem or your money back. Check your PM for my number.

Posted: Wed Nov 27, 2013 2:12 pm
by jengwe
Bro,

saw your previous posts. You seem to have had it for months and you persisted in continuing to drive it. That is not good.

If you have D blinking light, get the DTC code read and determine the specific electronic component that has fried in the gearbox.

Its that simple.

Likely to be the Control Valve Block, Drive speed sensor or Driven speed sensor, but to be sure, get that DTC code.

As the gearbox is a mechatronic system, more likely to be electronic failure than a mechanical one. However, if the fault is not quickly rectified, the mechanical portion will start to wear. Eventually due to your delayed action, when the fried electronic component gets replaced, your gearbox will likely to have suffered some permanent damage. Then too bad.

Go to a mech and get the specific DTC code, surf the net on the spot and determine the cause to verify that the mech is correct, then proceed to repair.

Do not be satisfied with a system reset.

If it is Control Valve Block, cost ard $400 for a new one. Replacement is just a matter of loosening 8 bolts.

Other gearbox elec components, easily can get it for ard $60 at the scrapyard. Replacement is just a matter of loosening 1-2 bolts.

No secret Kungfu... Learn to help yourself.

Get the drift.....